Posts Tagged ‘service builder’

I got few comments in my previous blog that the Service Builder functionality is broken in Portal Pack 3.0.4 & Liferay 6.0.5. After a  little investigation, I found that there are few changes in the new liferay release in service builder part.  I will fix that issue in the next release.

It is a regression and due to lack of QA resources, we could not test it.

Meanwhile, I would really like to know from the users that what are the features you are using most in Portal Pack ?  And any area where you want improvement ? These information are really critical for the next release, as I don’t have much bandwidth to develop and test everything 😦 . So based on your feedback I can priorities the areas and will make sure those would be tested properly in future releases.

Also based on your feedback, if there are more users using service builder plugin in Portal Pack, I will try to do a better integration for service builder plugin in Portal Pack.

Also if  you have any new suggestions or if you would like to contribute to this project in any way like QA or development, please let me know.

Cheers !!!

Updated:

There is a workaround or alternative which is little tricky.

– Please download the  servicebuilder.jar  from http://portalpack.netbeans.org/servicebuilder.jar

– Go to your ~userhome/.netbeans/6.9/ directory

– Remove the existing servicebuilder directory

-Unjar the downloaded jar inside ~userhome/.netbeans/6.9 directory

-Now try to generate the service without restarting NetBeans. It should work.

But if you restart your NetBeans, the servicebuilder directory will be overwritten with the default files. So you need to follow the above steps again.