Portal Pack 3.0.5 Beta for NetBeans IDE 7

Posted: July 16, 2011 in NetBeans, Technology
Tags: , , , , ,

Portal Pack 3.0.5 Beta for NetBeans IDE 7 is now available for download.

Few changes

  • Compatible with NetBeans IDE 7.x
  • Works with maven based web project
  • Works with Liferays maven projects
  • Service builder plug-in is compatible with Liferay 6.0.4 and later

I have released this as beta to address any major regressions before the main release. You can submit issues here.

Advertisements
Comments
  1. Kyriacos says:

    Hi! In page http://netbeans.org/bugzilla/buglist.cgi?product=contrib&order=Importance&limit=25 I see you have already fixed several issues. Is there a nightly build I can download instead of the standard 6.0.5 beta?

  2. Ales says:

    Hi, I would like to help with development, how can I get in? Could you please let me know? BTW you did amazing job and I love Portal Pack much more than Liferay IDE. We just need to keep it improving.

  3. Any chance of getting an update so the Portal Pack can be installed on NetBeans 7.1? Currently it gives an error due to NetBeans switching from org.netbeans.libs.commons_logging to org.apache.commons.logging.

    Ref: http://netbeans.org/bugzilla/show_bug.cgi?id=206253

  4. Chetan Chadalavada says:

    Good Job Satya. Thanks for passionately updating the Portal Pack even after leaving Sun. Cheers!!

  5. ceone says:

    I bypassed the problem:
    – open the generic portlets nbm with 7zip (or any other zip tool).
    – extract it to a folder
    – open info.xml and delete the reference to commons logging
    -recreate the zip file
    – rename it from .zip to .nbm

    ET VOILA’

  6. DJ says:

    First thanks for continuing to provide support for portal pack. I am wondering if there will be another VWP development project that support current versions of NB’s. Seems like that development and updating stop at NB 6.5/6.7 and was never resurrected. I am curious, is there a reason that a graphical development environment is not possible in version later than NB 6.5/6.7.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s